Compact Export

Compact Export


Ever exported a config from RouterOS and saw tons of lines of garbage you didn’t need or sometimes even recognize? If so, you will love this!

Starting from v5.12 compact export was added. It allows to export only part of configuration that is not default RouterOS config.

[admin@SXT-ST] /routing ospf> export compact

# jan/02/1970 20:16:32 by RouterOS 5.12

# software id = JRB7-9UGC

#

/routing ospf instance

set [ find default=yes ] redistribute-connected=as-type-1

/routing ospf interface

add disabled=yes interface=wlan1 network-type=point-to-point

/routing ospf network

add area=backbone network=10.255.255.36/32

add area=backbone disabled=yes network=10.5.101.0/24

add area=backbone network=10.10.10.0/24

[admin@SXT-ST] /routing ospf>

Compact export introduces another feature that indicates which part of config is default on RouterOS and cannot be deleted. As in example below ‘*’ indicates that this OSPF instance is part of default configuration.

[admin@SXT-ST] /routing ospf instance> print

Flags: X – disabled, * – default

0 * name=”default” router-id=0.0.0.0 distribute-default=never

redistribute-connected=as-type-1 redistribute-static=no

redistribute-rip=no redistribute-bgp=no redistribute-other-ospf=no

metric-default=1 metric-connected=20 metric-static=20 metric-rip=20

metric-bgp=auto metric-other-ospf=auto in-filter=ospf-in

out-filter=ospf-out

This entry was posted in Wireless Internet News by Steve Discher. Bookmark the permalink.

About Steve Discher

Steve Discher was born in Apple Valley, California and today makes his home in College Station, Texas with my wife and three children. He is a 1987 graduate of Texas A&M University and own ISP Supplies, a wireless distribution company, and conducts MikroTik training classes. His hobbies include flying my Piper Cub and RV camping with my family.

Leave a Reply